Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Thread Post New Thread    Reply
Registered User
Join Date: May 2012
Location: New Orleans, Louisiana
Posts: 516
Another top problem

Hey y'all. I'm knew to the BMW side of the forum. I have a Porsche but my mom has a Z4 so I take care of it. So the top broke before, my dad and I replaced the motor, modified it so it drains, then sealed the top so water cannot get in. It worked for a whole but now it just unlatches and the red light starts blinking. I can also hear right behind my right ear a fluid noise, like fluid is moving. I can hear the pump trying to engage as well. The micro switch is working fine, I tested it. Any ideas?

Old 07-05-2012, 09:01 PM
  Recommend this thread for the PelicanWiki    Reply With Quote #1 (permalink)
Registered User
Join Date: Aug 2012
Location: Chicago
Posts: 43
my suggestion is to go after a dealer and get it fixed. if you keep on trying it by your self.. it wont be fixed nicely, coz it is a complicated work.

Old 08-06-2012, 05:52 PM
  Recommend this thread for the PelicanWiki    Reply With Quote #2 (permalink)
Old 08-06-2012, 05:52 PM

Thread Tools
Rate This Thread
Rate This Thread:


All times are GMT -8. The time now is 10:16 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.