Pelican Parts
Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   Pelican Parts Technical BBS > Dave at Pelican Parts

Conversation Between Dave at Pelican Parts and John Leamon
Showing Visitor Messages 1 to 2 of 2
  1. Dave at Pelican Parts
    07-22-2014 11:41 AM - permalink
    Dave at Pelican Parts
    You either have a fuel pump problem, or a problem with the system that powers the pump and injection equipment. Check the fuses on the relay board, and check the wires going to the board. Also swap the relays on the board with your headlight relays, after making sure the latter will actually raise and lower your lights.

    --DD
  2. John Leamon
    07-22-2014 11:07 AM - permalink
    John Leamon
    1973 1.7 914 died while driving quite well. Would not start. When turning key to aux. there is no sound of the fuel spurt. I have checked for a spark and there is a good spark at the #3 wire. I don't know where to go from here. Frustrating since it was running well and starting easily. Thoughts?

All times are GMT -8. The time now is 06:42 PM.


 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2016 Pelican Parts - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page
 

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.