Pelican Parts
Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   Pelican Parts Forums > Porsche Forums > Porsche 911 Technical Forum


Reply
 
LinkBack Thread Tools Rate Thread
Author
Thread Post New Thread    Reply
Registered
 
Join Date: Mar 2018
Location: LA
Posts: 60
Recently Rear ended, clicking sound, loss of power

Well, this is a bum out post so look away if you're squeamish! Please note, I have no prior porsche experience, and have relied on this forum for all of my maintenance and advice! Thank you all!

The story: My 78 sc was running perfect. It's been documented from the day it left the showroom til now. Regular maintenance and really well taken care of. Then I was rear ended... not hard enough to make contact with the engine, but the rear panel needed to be replaced. So I get the car back and it's "different." I'll do my best to describe the symptoms and also include links to videos so you can hear the sound.

At first there was just a noticeable "shutter" or vibration that would happen at 2500-3000 rpm, accelerating or decelerating, it made no difference. I thought maybe it was an engine mount? One day after it was warmed up, and parked, I started it up and a clicking noise began to happen. I assumed it was a valve when I heard it seemingly coming from the bottom right side of the engine. It went away, the shutter continued but seemed less. Then today, while accelerating (not heavily), there was a noticeable loss of power in that same rpm range and a very loud click began. this click is loud and seems like something is loose, as it would vary in timing when I would let off on the gas. It definitely gave me a bad feeling in my gut... I was only .25 miles from home, so kept rpms below 2.5 and went strait into the garage.

I've searched quite a bit and everything I find somewhat similar doesn't experience power loss. Could something have happened at the shop? Did the jolt of the accident loosen something? Coincidence? Any insights would be greatly appreciated.

Driving (sound starts at :20 and :30 is bad):
https://youtu.be/Z8saFqu0pLI

Idle in garage:
https://youtu.be/kO70QtIf4G0

Old 02-08-2019, 08:39 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)
Reply

Thread Tools
Rate This Thread
Rate This Thread:

 

Tags
3.0 , 911sc , power loss


All times are GMT -8. The time now is 07:27 AM.


 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2020 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page
 

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.