Pelican Parts
Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   Pelican Parts Forums > Porsche Forums > Porsche 911 Technical Forum


Reply
 
LinkBack Thread Tools Rate Thread
Author
Thread Post New Thread    Reply
New kid in town
 
71T Targa's Avatar
 
Join Date: Nov 2001
Posts: 2,262
Optical ignition

Quick question about the Crane Optical Ignition. Should I be able to see the LED light up when there is power applied? Iím not getting spark and if I remove the distributor cap, I canít see the LED light. Not sure if I would have been able to when I was getting spark, or if I should be able to.

__________________
I wish I still had 9111113443...
Old 10-14-2005, 09:32 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)
Bill is Dead.
 
cashflyer's Avatar
 
Join Date: Jul 2005
Posts: 9,623
I'm running the XR-700-0231 system on my Fiat. I THINK the technical guy at Crane told me that the internal LED is IR - which means you would not see it.

HOWEVER- All newer XR-700 and XR-3000 units have a red LED "status light" on the side of the control box. When wired correctly and operating, you should see the light illuminated.

If you do not have the original instructions, these links may help:
For older unit WITHOUT red status light
For newer units WITH status light

If all else fails, call the tech line: 386-258-6174 (8-5 EST)
They were very helpful when I called asking questions prior to selecting their product. It's been running for better than 2 years now without fail - which is a lot more than I could say for the original Marelli equipment.
__________________
-.-. .- ... .... ..-. .-.. -.-- . .-.
The souls of the righteous are in the hand of God, and no torment will ever touch them.
Old 10-14-2005, 09:54 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #2 (permalink)
New kid in town
 
71T Targa's Avatar
 
Join Date: Nov 2001
Posts: 2,262
OK, Thanks. The car was running great, and I was loving the new ignition without points. Then the car sat for a month and now it wont fire. I'll start trouble shooting, but started with looking at the LED...
__________________
I wish I still had 9111113443...
Old 10-14-2005, 11:26 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #3 (permalink)
Bill is Dead.
 
cashflyer's Avatar
 
Join Date: Jul 2005
Posts: 9,623
This is just somewhere to start.....

Get somebody to watch the status LED while you crank it over. (it may help if the LED is shaded / not in direct light) Your helper should be able to see it flicker every time the shutter crosses the beam in the distributor. If you do not get the flicker, then you may have a wire loose to the controller or to the sensor in the distributor. Or the controller could be dead, but I don't know why if it's just been sitting for a month.

__________________
-.-. .- ... .... ..-. .-.. -.-- . .-.
The souls of the righteous are in the hand of God, and no torment will ever touch them.
Old 10-14-2005, 12:31 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #4 (permalink)
Reply

Thread Tools
Rate This Thread
Rate This Thread:

 


All times are GMT -8. The time now is 01:25 PM.


 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2020 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page
 

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.