Pelican Parts
Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   Pelican Parts Forums > Porsche Forums > Porsche 911 Technical Forum


Reply
 
LinkBack Thread Tools Rate Thread
Author
Thread Post New Thread    Reply
Registered User
 
OZCarrera3's Avatar
 
Join Date: Jul 2003
Location: Brisbane, Australia
Posts: 578
Garage
Question Pedal Cluster Rebuild Gone Bad

I've just completed a rebuild of my pedal cluster and replacement of the clutch cable, clutch cable return spring and the omega spring on the gearbox.

I now have a problem that has me tearing (whats left of) my hair out!

My accelerator will not return the top of its travel causing the engine to race at about 3,000rpm. I have to pull the accelerator back about an inch to get the engine to return to idle.

I've checked the movement at the pedal linkage at the pedal cluster and there is absolutely no binding or stiction from the bushes. I've checked the bushes at the engine linkage area and they too have no binding or stiction. I've also checked the accelerator linkage pivot point in the gearbox and this too is ok. All the appropriate accelrator linkage springs are in place. The only place I can find any sort of resistance is with the accelerator linkage rod that travels up the transmission tunnel. All I can think of is that the new clutch cable is interfering with the linkage rod. I have tried pulling the linkage rod out, but it gets stuck and won't come out.

My question is, should this rod come out easily if it is disconnected at both ends? Does it make sense that the linkage rod is rubbing or dragging against the clutch cable?

__________________
Sheldon
'92 964 Carrera 2 (Manual)
'07 BMW 335i
'76 911 Carrera 3.0 (Gone, but not forgotten)
"Give me ambiguity or give me something else!"
Old 07-12-2010, 03:15 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)
Bird. It's the word...
 
Fishcop's Avatar
 
Join Date: Feb 2001
Location: Port Macquarie NSW Australia
Posts: 5,077
Garage
Sheldon, did you replace/fiddle/dislodge the 3 tunnel accelerator linkage bushes?
__________________
John Forcier
Current: 68L 2.0 Hotrod - build underway
Old 07-12-2010, 03:33 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #2 (permalink)
Registered User
 
OZCarrera3's Avatar
 
Join Date: Jul 2003
Location: Brisbane, Australia
Posts: 578
Garage
...there are tunnnel bushes??

G'Day John, how you feeling? Over your flu?

How do you check these? I guess I noticed one at the firewall, a rubber cylindrical looking thing with a concertina dust cover.
__________________
Sheldon
'92 964 Carrera 2 (Manual)
'07 BMW 335i
'76 911 Carrera 3.0 (Gone, but not forgotten)
"Give me ambiguity or give me something else!"
Old 07-12-2010, 03:39 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #3 (permalink)
Registered User
 
Join Date: Oct 2009
Location: Houston
Posts: 1,288
Garage
Clutch cable is fouled. Pull it out and then test the throttle for proper action. If it goes to idle properly, your found the problem. Reinstall clutch cable making sure it goes in straight and does not wrap the throttle rod.

Lindy
Old 07-12-2010, 06:26 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #4 (permalink)
Registered User
 
Join Date: May 2002
Location: Lakeville, Minnesota
Posts: 1,116
Garage
Quote:
Originally Posted by lindy 911 View Post
Clutch cable is fouled. Pull it out and then test the throttle for proper action. If it goes to idle properly, your found the problem. Reinstall clutch cable making sure it goes in straight and does not wrap the throttle rod.

Lindy
I agree, this is not uncommon when the clutch cable is replaced.

Jerry M
'78 SC
Old 07-12-2010, 06:29 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #5 (permalink)
Registered User
 
OZCarrera3's Avatar
 
Join Date: Jul 2003
Location: Brisbane, Australia
Posts: 578
Garage
Thanks guys will give that a try!

__________________
Sheldon
'92 964 Carrera 2 (Manual)
'07 BMW 335i
'76 911 Carrera 3.0 (Gone, but not forgotten)
"Give me ambiguity or give me something else!"
Old 07-12-2010, 03:43 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #6 (permalink)
 
Reply

Thread Tools
Rate This Thread
Rate This Thread:

 


All times are GMT -8. The time now is 03:02 PM.


 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2020 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page
 

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.