Pelican Parts
Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   Pelican Parts Forums > Porsche Forums > Porsche 914 & 914-6 Technical Forum


Reply
 
LinkBack Thread Tools Rate Thread
Author
Thread Post New Thread    Reply
Registered User
 
Join Date: Oct 2004
Location: Weatherford, Texas
Posts: 4
Fuel Pump Woes, 75 914

Trying to get fuel to flow after the car has sat in my garage for five years. Here is what has transpired:

Added approx 5 gals. of fuel
Charged Battery,
Turned key and hear pump run but it sounds dry.
Try about 5-6 more times but sounds the same.
Pull inlet side (big line between filter and pump).
Gas barely drizzles out.
Pull tank, clear dirt dobber mud out of line.
Reattach pump.
Turn key, can hear pump engage but it is not turning.
Voltage at pump is 9.8 volts, 12.93 at the battery

So have I burned it up? Shouldn't voltage at the pump be 12 v?
Old 04-23-2006, 12:58 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)
Registered User
 
Headrage's Avatar
 
Join Date: Jul 2004
Location: Bakersfield, Ca.
Posts: 477
Still d-jet?

Pump should only run for 1 -2 seconds...
Old 04-23-2006, 01:09 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #2 (permalink)
Reply

Thread Tools
Rate This Thread
Rate This Thread:

 


All times are GMT -8. The time now is 04:25 PM.


 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page
 

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.