Pelican Parts
Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   Pelican Parts Forums > Porsche Forums > Porsche 914 & 914-6 Technical Forum


Reply
 
LinkBack Thread Tools Rate Thread
Author
Thread Post New Thread    Reply
Registered User
 
Join Date: Feb 2004
Location: Sacramento
Posts: 7
Front Suspension rattle What am I missing?

I'm trying to work through a front suspension rattle when going over bumps. I replaced front strut inserts, tie rod ends, and re-tightened the wheel bearings. I also re-checked the front mount nuts for the strut inserts to make sure they are tight. I am still getting the rattle when driving over small bumps. I noticed that after I adjusted the wheel bearings, I had play in the bearings come back after the test drive, so I suspect the bearings may be shot and adding to the problem. Is there anyting else I should check that I may be missing?
Thanks
__________________
Nowlings
Old 10-28-2007, 08:06 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)
Registered User
 
Join Date: Apr 2005
Location: Gibson City, Il
Posts: 10
Check your brake pad anti rattle clips. Brake pads can rattle like hell if they aren't in there. Easy way to tell is to hit the brakes slightly when you are hearing this rattle.
Old 10-29-2007, 11:52 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #2 (permalink)
Registered User
 
Join Date: Feb 2004
Location: Sacramento
Posts: 7
thanks for the tip... I will check tonight
__________________
Nowlings
Old 10-29-2007, 12:29 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #3 (permalink)
Registered User
 
Join Date: Oct 2001
Location: Gautier Ms
Posts: 1,582
Garage
shock pistons don't fit snug in the shock mount. there are different diameters and a fitted bushing will fix it.
Old 11-07-2007, 04:25 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #4 (permalink)
Registered User
 
Join Date: Feb 2004
Location: Sacramento
Posts: 7
Thanks.... I located the issue which ended up being a loose strut insert. Removed strut and resecured insert and re installed. OK now.. Thanks for the input.
__________________
Nowlings
Old 11-07-2007, 08:20 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #5 (permalink)
Registered User
 
Join Date: Oct 2001
Location: Gautier Ms
Posts: 1,582
Garage
Cool What do I win?????
Old 11-08-2007, 05:17 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #6 (permalink)
Reply

Thread Tools
Rate This Thread
Rate This Thread:

 


All times are GMT -8. The time now is 08:44 AM.


 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page
 

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.