Pelican Parts
Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   Pelican Parts Forums > Porsche Forums > Porsche 924/944/968 Technical Forum


Reply
 
LinkBack Thread Tools Rate Thread
Author
Thread Post New Thread    Reply
Registered User
 
Join Date: Aug 2019
Posts: 26
Starting problem

After months of rebuilding the steering rack and pump and waiting on a new compressor I just finished installing the pump compressor and rack but I tried starting it up and the belts turn for less than a second but then stops and nothing happens
It's not the battery because the inside lights are fine and I recently replaced the battery

Maybe one of the belts is too tight?
Old 10-01-2019, 02:32 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)
Registered User
 
Join Date: Oct 2006
Location: va
Posts: 2,178
Garage
What is the battery voltage? It could need a charge after sitting for a while. You could also get it load tested.
Old 10-01-2019, 03:32 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #2 (permalink)
Registered User
 
Join Date: Aug 2019
Posts: 26
Quote:
Originally Posted by djnolan View Post
What is the battery voltage? It could need a charge after sitting for a while. You could also get it load tested.
I dont have the equipment for that but I'll try jumping it
Old 10-01-2019, 04:10 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #3 (permalink)
Reply

Thread Tools
Rate This Thread
Rate This Thread:

 


All times are GMT -8. The time now is 02:10 AM.


 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page
 

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.