Pelican Parts
Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   Pelican Parts Forums > Porsche Forums > Porsche 924/944/968 Technical Forum


Reply
 
LinkBack Thread Tools Rate Thread
Author
Thread Post New Thread    Reply
Registered User
 
J1NX3D's Avatar
 
Join Date: Feb 2001
Location: Christchurch, New Zealand
Posts: 2,050
Garage
Question 944 Cooked Rings

Hey guys!
One of my mates has a Euro '83 944 5-spd.
Hes had engine temps soaring last 2 times hes driven it, now it won't turn over at all- in his words:
"...temp maxed out for a couple of minutes. Doesn't start now, just screatches and scrapes..."

Questions:
1. Does this sound like cooked rings? If not then wot could it be?

2. Wot other symptoms should he have with cooked rings?

3. Wot is required in parts and labour to fix?

Thanx in advance
mAd

p.s. starter/ battery r sweet

Old 05-31-2001, 01:47 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)
Registered User
 
J1NX3D's Avatar
 
Join Date: Feb 2001
Location: Christchurch, New Zealand
Posts: 2,050
Garage
Post

pps, u guys are almost 19hrs behind me!!
Old 05-31-2001, 01:48 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #2 (permalink)
Registered User
 
88_944's Avatar
 
Join Date: Apr 2001
Location: HAWAII
Posts: 492
Garage
Cool

Quote:
"...temp maxed out for a couple of minutes.
I can't believe he maxed out the temp. He should have stop the engine when it was about 3/4 hot. I think the cam housing or the head is warped. I think it can't be the rings. It's the upper half of the engine that is damage.

------------------
PORSCHE There is no Substitute!

[This message has been edited by 88_944 (edited 05-31-2001).]
Old 05-31-2001, 03:30 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #3 (permalink)
Registered User
 
Join Date: Nov 2000
Location: Tallahassee, FL, US
Posts: 52
Lightbulb

Dont freak out just yet, there are a number of things that could be the problem. There is a safety mechanism that does not allow the car to start when the temp is truley at the max of the temp gauge. I had this problem about four weeks ago and it was a simple fix. My problem was that my thermostat had gone bad and locked up. It was not allowing coolant to reach the radiator. I even tried to flush the radiator first, before I realized what the problem was and the coolant shot out the expansion tank. Anyway, I replaced the thermostat with a lower temp one, flushed the system and everything has been great. I also added Water Wetter into the expansion tank to help lower the temp even more. I recommend changing the thermostat first and go from there, they are only around $20. Good luck.

Old 05-31-2001, 10:07 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #4 (permalink)
Reply

Thread Tools
Rate This Thread
Rate This Thread:

 


All times are GMT -8. The time now is 07:48 AM.


 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2020 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page
 

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.