Pelican Parts
Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   Pelican Parts Forums > Porsche Forums > Porsche 924/944/968 Technical Forum


Reply
 
LinkBack Thread Tools Rate Thread
Author
Thread Post New Thread    Reply
Registered User
 
max29a's Avatar
 
Join Date: Jul 2004
Location: Santa Barbara, CA
Posts: 90
what a newb did this weekend with pics

Well still trying to track down my enging hesitation/stuttering/power loss problem still.

Please comment on anything you see fit. I am always looking for advice.

This weekend I jacked the car up, undid the fuel pump area strap, undid 2 screws and disconnected the fuel line as per clark's. Took the fuel pump screen out and inspected and cleaned it. Very easy job, but the screen looked pretty damn good for being 20 years old. No holes and just some really fine metal particles trapped on the outside.

Then I checked my spark plugs. #1 looks like maybe it has a bit of burnt oil. Please tell me what you think. Its been in the car about 8 months/15k miles. I replaced all plugs because I did not have a gapping tool and I could swear the gaps were different to the naked eye, but upon further inspection I think they were the same. Oh well I got bosch platinum 2's.

I took off the distributor cap and checked the rotor. I have no experience with what it should look like so I took a picture, but I am guessing its fine.

Then I went after the ignition switch. I tried to follow clark's but a) it starts out with a guy who has a non-stock steering wheel and b) it shows an early I guess and I have late and they are way different. It took me about half way through to realize this or else I would have took pics and documented the whole thing but the process is way different including removing a lot of trim panels that you dont have to do on early apparently.

I got in and took out the ignition switch and it looked fine to me. I also went and removed my guages while I was in there and cleaned the contacts. I really should have replaced light bulbs but I didnt have any, but it didnt seem all that hard to get back in there, now that I know what to do. If anyone needs help with this process I can write it up.

Finally I poured some STP injector cleaner in my fuel tank. I have no idea if this stuff is worthwhile or not, but my problem has definitely died down some. I am starting to wonder if this stuttering could be caused somehow by putting in 87 octane gas. I know that is what the manual says, but if I understand correctly the injector cleaner is mainly high octane gas + some other stuff. Next tank I will try 92 and see what happens.

Final notes: I am going to rig up a fuel pressure tester to check fuel pressure. Also perhaps I should check and clean the fuel injectors. I seem to recall that this is very dangerous as something is liable to break when removing injectors? I will search.

If I don't find anything there then I guess its time to take it to a mechanic and see if they can help me. Things I have now done to fix stuttering/enging power loss:

check fuel pump screen
replace fuel filter
replace spark plugs
replace ignition coil, cap, rotor and wires
check ignition switch
replace battery, clean any grounds I can see (is there a list somewhere?)


__________________
1985.5 944 NA - 270k miles!
2001 suzuki sv650 - 37k miles

oil change done at 270k
timing belt done at 240k
Old 04-18-2005, 09:16 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)
Registered User
 
Rmills944's Avatar
 
Join Date: Oct 2004
Location: Memphis
Posts: 340
Send a message via AIM to Rmills944 Send a message via Yahoo to Rmills944
Good choice on replacing those plugs - they look real nasty.
__________________
Ryan
'84 944 moneysucker edition (SFR, Corbeaus, etc.)
'02 Jetta TDI 280Lb/Ft 145Hp @ wheels. RC2 PP357's
Old 04-18-2005, 09:20 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #2 (permalink)
Composite Shop Owner, DJ
 
MixMasterK's Avatar
 
Join Date: Oct 2001
Location: Saint Helens, OR, USA
Posts: 397
Send a message via MSN to MixMasterK Send a message via Yahoo to MixMasterK
I always run Supreme Unleaded in mine. Cost sucks, but it's worth it.

__________________
'86 944, 5 Speed (Daily Driver)
Old 04-18-2005, 10:16 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #3 (permalink)
Reply

Thread Tools
Rate This Thread
Rate This Thread:

 


All times are GMT -8. The time now is 09:29 PM.


 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page
 

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.