Pelican Parts Forums

Pelican Parts Forums (http://forums.pelicanparts.com/)
-   Porsche 924/944/968 Technical Forum (http://forums.pelicanparts.com/porsche-924-944-968-technical-forum/)
-   -   '79 924 fuel pressures issues (http://forums.pelicanparts.com/porsche-924-944-968-technical-forum/634517-79-924-fuel-pressures-issues.html)

Gene321 10-13-2011 09:47 AM

'79 924 fuel pressures issues
 
When I do a fuel pressure test on the car which is barely running hot or cold I get system fuel pressure of 72 LBS which is normal but when I flip the pressure gage valve to check control pressure I still get 72 LBS pressure which shouldn't be over 57. Any one else had this problem ? I think my fuel distributer is dirty or shot ?? Help !

924RACR 10-14-2011 03:43 AM

It's the warmup regulator, aka control pressure regulator, not the fuel dizzy.

SpecialTauto (.com) has some good rebuilt options...

Gene321 10-15-2011 07:58 AM

I replaced the wur a few days ago, didn't help other than it starts easier now, no the problem still exhists, runs like crap cold or hot at 1 - 3 grand only, osasionally will get up to 4 grand for short time.

924RACR 10-16-2011 04:13 AM

With new or used?

Gene321 10-17-2011 10:03 AM

Rebuilt one, also had taken the one from my rabbit convertable cis injection and installed on 924 with no improvement so had two wur's on and still the same problem of to high a control pressure of 72 LBS

924RACR 10-17-2011 11:25 AM

Next thing to check - perhaps the return line to the tank is blocked? Never experienced that myself, but it would explain. That or the plumbing's not routed correctly...

Gene321 10-22-2011 08:58 AM

I checked the return line and its fine. The pressure gadge is giving me different reading last time I checked it, when I flip the lever on gadge to control pressere now for a split second it goes down into the 50's LBS and gradually creaps up to around 70 LBS and some times I can get the engine up to 6 grand now. The first time last July when car screwed up for the first time it came out of the problem gradually in a weeks time, ran great till the other week.
Plumbing cant be wrong as I changed nothing and car runs fine sometimes but not lately .


All times are GMT -8. The time now is 09:24 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website


DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.