Pelican Parts
Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   Pelican Parts Forums > Porsche Forums > Porsche 924/944/968 Technical Forum


Reply
 
LinkBack Thread Tools Rate Thread
Author
Thread Post New Thread    Reply
Registered User
 
Join Date: Jan 2012
Location: NW Ohio
Posts: 7,102
PS pump whine...belt or rebuild ?

I just picked a really nice 85.5 944 with virtually everything that could be replaced mechanically has been done recently with a folder full of expensive receipts from a local shop near where the P.O. lives (300 miles from me).

Everything on the car works well but I noticed on a cold startup, the PS pump whines and really gets loud when I turn the wheel (revving the car does not change the noise unless the wheel is turned).

I was wondering if you guys thought it might be a over tensioned belt that was replaced earlier this year along with the other important belts, seals, and WP, and only driven 100 miles before I bought it. or if the pump needs one of those rebuild kits with the O-rings, and washer.

It also looks like the PS rack was bebuilt about 15,000 miles ago, so I can't think there is anything going on there.
Old 11-15-2012, 08:40 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)
Registered User
 
ernie9944's Avatar
 
Join Date: Oct 2008
Location: Caraquet, New-Brunswick, Canada
Posts: 3,283
Garage
Are you sure you got the rigth kind of fluid in it,Porsche PS need ATF in it ( not power steering fluid).Using ATF +3 Super Pro RXL 1 in mine without issues up to date.
__________________
83-944 show room -sold___New ride 93-968 with SC steering wheel-ROW signal ligths- Susp M030 mods lowered,Porsche VA springs- Adjustable struts - Bilstein inserts - Bilstein sport rear -LSD -riding on Cup 1 wheels 17x8 frt 17x9.5 rear road contact Falken 452/ 225-45 ZR Front 255-40 ZR Rear -- Motor Mods /chip /K&N / mod air boxe just love the handling & power
Old 11-15-2012, 11:45 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #2 (permalink)
Registered User
 
ernie9944's Avatar
 
Join Date: Oct 2008
Location: Caraquet, New-Brunswick, Canada
Posts: 3,283
Garage
Forgot,also check Clark's Garage Home Page for trouble shooting.Once on main page click (Garage Shop Manuel)
__________________
83-944 show room -sold___New ride 93-968 with SC steering wheel-ROW signal ligths- Susp M030 mods lowered,Porsche VA springs- Adjustable struts - Bilstein inserts - Bilstein sport rear -LSD -riding on Cup 1 wheels 17x8 frt 17x9.5 rear road contact Falken 452/ 225-45 ZR Front 255-40 ZR Rear -- Motor Mods /chip /K&N / mod air boxe just love the handling & power
Old 11-15-2012, 11:51 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #3 (permalink)
Redline Racer
 
HondaDustR's Avatar
 
Join Date: Jan 2007
Posts: 2,438
Yes, sounds like a fluid problem. It's driven by a v belt which will almost never make a whining noise.

I'd drain and flush with a good ATF. Low fluid level can also cause whining.
__________________
1987 silver 924S made it to 225k mi! Sent to the big garage in the sky
Old 11-15-2012, 08:01 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #4 (permalink)
Registered User
 
Join Date: Jan 2012
Location: NW Ohio
Posts: 7,102
It was whining at first and I checked the fluid level.....it was low and only registered on the very tip of the cap indicator. I then added the wrong stuff (Prestone power steering fluid), drove it and checked it again and saw the fluid all foamed up.

After 1/4 mile of driving there is no more whining sound.
Old 11-16-2012, 03:29 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #5 (permalink)
Redline Racer
 
HondaDustR's Avatar
 
Join Date: Jan 2007
Posts: 2,438
You need to flush that cocktail out and replace with ATF or it will do bad things to your seals in the long run.
__________________
1987 silver 924S made it to 225k mi! Sent to the big garage in the sky
Old 11-16-2012, 07:58 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #6 (permalink)
 
Registered User
 
Join Date: Jan 2012
Location: NW Ohio
Posts: 7,102
Yea, here within a week or two, I will get the pump rebuild kit and flush the system out, replace the belt, and put the proper ATF in, and hopefully that will take care of any problems.
Old 11-16-2012, 08:22 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #7 (permalink)
Toofah King Bad
 
Rasta Monsta's Avatar
 
Join Date: Oct 2006
Location: PacNW
Posts: 3,848
Garage
Power steering fluid out ASAP, will destroy seals rather quickly.
__________________
» 1980 931 - Got boost? ♦ 1987 924S - Pro44 ♦ 1987 924S - Junkyard score «

"DETERMINATION. Sometimes cars test us to make sure we're worthy. Fix it." - alfadoc
Old 11-16-2012, 08:53 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #8 (permalink)
Registered User
 
Join Date: Jan 2012
Location: NW Ohio
Posts: 7,102
Can I use Mobil 1 Dexron lll fully synthetic in the power steering resevoir, or does it have to be non-synthetic ?
Old 03-12-2013, 02:42 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #9 (permalink)
Toofah King Bad
 
Rasta Monsta's Avatar
 
Join Date: Oct 2006
Location: PacNW
Posts: 3,848
Garage
You've been running power steering fluid in that thing for three months? The rack also contains seals that are destroyed by the wrong fluid.

You need to flush and fill, synthetic not a problem. Also replace reservoir. . .contains a fluid filter and is meant to be discarded as regular service.

Finally, whine can be caused by cavitation from leaking connections between the feed line and the pump (updated by Porsche TSB), and by a leaking, worn out line.
__________________
» 1980 931 - Got boost? ♦ 1987 924S - Pro44 ♦ 1987 924S - Junkyard score «

"DETERMINATION. Sometimes cars test us to make sure we're worthy. Fix it." - alfadoc
Old 03-12-2013, 09:06 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #10 (permalink)
Registered User
 
Join Date: Jan 2012
Location: NW Ohio
Posts: 7,102
No, I have only started the car 3 times since then with the PS fluid in there. I have been working alot, and it has been too cold to attempt anything outside.
Old 03-13-2013, 12:40 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #11 (permalink)
Reply

Thread Tools
Rate This Thread
Rate This Thread:

 


All times are GMT -8. The time now is 04:45 AM.


 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page
 

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.