Pelican Parts
Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   Pelican Parts Technical BBS > 1- Porsche Technical Forums > 911 / 930 Turbo & Super Charging Forum


Reply
 
LinkBack Thread Tools Rate Thread
Author
Thread Post New Thread    Reply
Registered User
 
Join Date: May 2006
Location: Newcastle Upon Tyne UK
Posts: 12
new coil and ignition unit causing problem

Hiya guys.....
I would really appreciate some advice on a problem i have with my 86 930.

Car was recently fitted with a new permatune ignition unit and new coil (std bosch unit) after they decided to fry themselves in Malaga city.
(this was an embarrassing episode as i coasted to a halt smack bang in front of a busy dept store. I took the abuse from the many Spanish shoppers well enough, and eventually got out of there on the back of a truck).

Since installing the new parts, i notice that the front fuel pump now runs when ignition is switched on. This never happened previously.
The idle is also rough and the car runs really rich, until the car is warmed up thoroughly
If i stall during the warm up, it is also difficult to re-start.
Once warmed up, no problems at all.

Previous to fitting new parts, i had no hot/cold start problems.

Any suggestions as to what could be causing this will be greatly appreciated.

All the best

Dave.
Old 11-10-2008, 08:32 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)
OFF THE BOOST PIPE NOW...
 
A930Rocket's Avatar
 
Join Date: Oct 2003
Location: Mount Pleasant, South Carolina
Posts: 7,092
If the car was running good prior to the Permatune and coil install, I would look into both of those. Is the coil compatible with the Permatune? Is a special coil required?

You may want to think about a MSD6AL ignition and MSD Blaster 2 coil.
Old 11-10-2008, 06:42 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #2 (permalink)
Registered User
 
Join Date: May 2006
Location: Newcastle Upon Tyne UK
Posts: 12
Quick update.
Problem sorted....removed and refitted fuel pump relays.
Wish things were always this simple!!!!!.

Regards.

Dave.
Old 11-13-2008, 06:05 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #3 (permalink)
Registered User
 
Join Date: Oct 2006
Location: Chas, SC
Posts: 980
Quote:
Originally Posted by A930Rocket View Post
If the car was running good prior to the Permatune and coil install, I would look into both of those. Is the coil compatible with the Permatune? Is a special coil required?

You may want to think about a MSD6AL ignition and MSD Blaster 2 coil.
I see you corrected your problem, but for future potential problems, I do believe that permatune strongly recommends their coil be used with their CD.
__________________
Tim
1986 930
Gone:71,2,4 914's, 70T, 71T(RS),77S
Old 11-13-2008, 07:41 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #4 (permalink)
Reply

Thread Tools
Rate This Thread
Rate This Thread:

 


All times are GMT -8. The time now is 01:29 AM.


 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page
 

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.