Pelican Parts
Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help

Go Back   Pelican Parts Technical BBS

rkeele rkeele is offline

Registered User

Visitor Messages

Showing Visitor Messages 1 to 3 of 3
  1. rkeele
    05-19-2017 08:46 AM - permalink
    One time I had 2 wires disconnected another I was missing the WOT wire from the DME box very weird ran a new wire, last time it was nothing more than crossed ignition wires at the plug easy to do with 12 plugs, stupid me so when I plugged in the second igniter it would backfire and hardly run,
  2. rkeele
    05-19-2017 08:18 AM - permalink
    that is funny mine is pronounced Keel E , Iv'e had so many little problems in the past witch one are you having?
  3. 914986
    05-16-2017 03:33 PM - permalink
    I'm experiencing the same ignition problems you had with your 964 back in June of 2014. I know it was a connector at the ignition module, but can you give me any more details? Thanks in advance!

    I don't know if your last name is Keele, funny coincidence mine is Kiehl (pronounced Keel)

About Me

  • About rkeele
    Laguna Hills Ca.


Total Posts
Visitor Messages
General Information
  • Last Activity: Today 12:43 PM
  • Join Date: 01-29-2012


All times are GMT -8. The time now is 03:15 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2017 Pelican Parts LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.