Pelican Parts
Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   Pelican Parts Forums > Porsche Forums > Porsche 914 & 914-6 Technical Forum


Reply
 
LinkBack Thread Tools Rate Thread
Author
Thread Post New Thread    Reply
Registered User
 
John Rogers's Avatar
 
Join Date: Dec 1969
Location: chula vista ca usa
Posts: 5,206
Left turn signal/flasher problem

I hate electrical problems! The left turn signals do not flash on the 1973 914 race car, BUT, when I pull the emergency flasher, fuse 11 blows, the right signals work fine, there are no shorts/grounds in the left bulb housings (front & rear, I checked), I tried a new flasher relay & no difference and if I put the left or right signal on with key off the running lights on that side light up as they are supposed to. Additionally I checked the emergency brake switch, it's okay, I unhooked/bypassed/grounded the master cylinder switch (it has no reset) and it made no difference, all bulbs are tested okay (new and correct #s) and finally the flasher relay is active all the time and the brake warning light is flashing. I can pull the red wire on the emergency flasher and it stops flashing and of course no signals work? I am thinking a short in the left side wires, but if I unhook them from the flasher it still causes the warning light to flash or finally maybe the turn signal internals have shorted? Anyone have this happen before?
Old 01-13-2000, 07:58 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)
Registered User
 
Join Date: Aug 1999
Location: Sunnyvale,Ca,USA
Posts: 159
I have the same problem on my '73 and I just replaced the entire front wiring harness because it had other problems. I determined the left flasher not working due to the turn signal switch. Good luck.

------------------
Quote:
THE NIGHT TIME IS THE RIGHT TIME

***AGENT 009, JAMES BONDO***

Old 01-13-2000, 09:32 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #2 (permalink)
Registered User
 
John Rogers's Avatar
 
Join Date: Dec 1969
Location: chula vista ca usa
Posts: 5,206
Well I found the problem, actually two problems??? The left turn signal was caused by the switch in the column going bad and it was also the cause of the horn not working. There is a plug that can be pulled if you look in the holes right under the steering column and I jumpered the wires for left and for right and the lights worked. So I pulled both column switches since they do get in the way on a race car and put in an on-off-on momentary toggle for the turn signals and a momentary on switch for the flasher relay and they all work fine. The blinking brake light was caused by a short in the wire to the emer brake switch so I just pulled the wires to/from the switch and all is fine since the flashing red light is not needed. I sure hate electrical problems!!
Old 01-19-2000, 06:28 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #3 (permalink)
Reply

Thread Tools
Rate This Thread
Rate This Thread:

 


All times are GMT -8. The time now is 05:28 AM.


 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page
 

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.