View Single Post
platinum944 platinum944 is offline
Registered User
 
Join Date: Jul 2010
Posts: 8
Garage
Porsche Crest what the heck is this part in my engine!!!

Hi all! Thank you to everyone who answered my last questions, it was a huge help…BUT now I have a new one….so while removing the crappy aftermarket alarm the previous owner had installed, I came across something in my engine bay that I cant find listed ANYWHERE!!!!! Not in my Haynes manual, not through the other forum I belong to…. It's mounted to the passenger side front strut/shock assembly, on the inside of the engine bay, with a rear facing orientation in other words, its between the firewall and the strut tower….its round and flat, like a flying saucer…. It has a positive and a negative cable running to it, and what appears to be two adjustment screws beneath plastic caps all of which are on the top of it. It has no other lines going into or away from it….the weirdest thing, is that the only reason I noticed it, was there was no longer a positive lead connected to it, and I cant even find a wire long enough to go to it anywhere near it. Also, the car was running just fine when I parked it two months ago to begin the interior restoration, so my question in a nut shell…what is this thing, and since it wasn't hooked up, does that mean its a completely unnecessary to the proper running of the car. I dont have a pic as my phones camera is all jacked up, but if no one can help I will try and post one in a few days. Thanks in advance everyone for any help you can give me, this part has been gnawing at my brain for three days!!!!!
Old 08-01-2011, 11:47 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)