Pelican Parts
Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   Pelican Parts Forums > Porsche Forums > Porsche 911 Technical Forum


Reply
 
LinkBack Thread Tools Rate Thread
Author
Thread Post New Thread    Reply
jtx jtx is offline
Registered User
 
jtx's Avatar
 
Join Date: Mar 2020
Location: Devon UK
Posts: 1
Garage
Porsche Crest 911SC idle and running issues

After spending hours reading through all the related posts on this great forum I decided it was time to ask for some desperately needed help.

The car is a 1980 model but was built mid 1979 so its pre oxygen sensor 930/09 engine plus it has a two in/out SS exhaust with no cat.

Fuel system is standard CIS setup. The car is mostly stripped out for track use.

I purchased the car back in Dec 19, previously had sat for 4.5 years without being run. Previous owner started it the day before I collected and apart from the usual white smoke it ran and was driven on to the transporter. But rapidly went downhill after that, I put this down to the fact that the old fuel clogged everything in the fuel system.

I have now meticulously gone through everything that you would expect could need attention, this included:

Fuel

Tank out cleaned, all new fittings and pipes
New fuel pump + relay
New fuel filter
New FD and WUR provided by https://www.kmipetrolinjection.co.uk
New fuel lines
Air flow sensor cleaned and check for correct setup
Air box was blown and has been repaired and pressure tested
All new rubber runner connection tubes
New injectors, injector inserts and seals
AAR cleaned and tested and ok
AAV replaced
Deceleration valve tested ok
Cold start valve tested ok

Ignition

New Classic retrofit CDI box
New plugs
New Beru leads
New distributor cap/rotor

Other

New voltage reg
New alternator
Oil changed
Tappets adjusted

So as you can see a lot has been changed.

Current measurements:

System pressure 4.9bar
Control pressure warm with vac on - 3.2bar, this is slightly below spec however I sent the WUR back to https://www.kmipetrolinjection.co.uk to be checked and they assure me that it is in spec and that my gauge is reading slightly low.
Cylinder compression (PSI read with air temp at 12deg and engine not fully warm) 1 - 125, 2 - 120, 3 - 122, 4 - 123, 5 - 124, 6 - 122 - Although these are all similar they are a on the low side, could this be the issue? The car has covered 160k, a top end rebuild was done at 150k but this was in 2001

The car starts but is rough at idle, revs up ok but poor pickup, at higher rpm appears to run smoother but still sounds like its missing.

Plugs foul up quickly with black soot suggesting she is very rich.

Haven't changed the coil which looks like the original Bosch 0221 121 001, meter readings are correct for both coils.

Mixture

Set to base setting as per manual and attach CO meter
CO meter says 5%, so slowly lean it out and CO comes down. As soon as we go below 4% she starts to backfire through the induction popping the pop-off valve.

Here are some videos of the car running, just:

https://youtu.be/UQ5PeCkOJiI

https://youtu.be/ZI_ccbgEbH4

Thanks in advance for any help...

Old 05-18-2020, 02:41 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)
Reply

Thread Tools
Rate This Thread
Rate This Thread:

 

Tags
911sc bad idle , 911sc cis issues , 911sc mixture , 911sc running rich


All times are GMT -8. The time now is 06:01 PM.


 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2020 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page
 

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.