Pelican Parts
Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   Pelican Parts Forums > Porsche Forums > Porsche 914 & 914-6 Technical Forum


Reply
 
LinkBack Thread Tools Rate Thread
Author
Thread Post New Thread    Reply
Registered User
 
swbstudios's Avatar
 
Join Date: Dec 2006
Location: the OC
Posts: 323
Garage
914 2.0 quits after running for ten minutes?

Hi, I have a 73 914 2.0. It starts and runs fine. When I drive on the highway at 75 or so, it will just shut off. It doesn't really sputter or buck, just shuts down. I coast to a stop, wait about five minutes and it will refire and drive normally. It will then quit at highway speeds after a few minutes. Today, I decided to try and drive home using city streets. The car ran well for over an hour in stop and go city driving. Although it did seem to nearly die at idle once or twice.
Any ideas? coil?
Thanks
__________________
67 911 vintage racer twin plug hotrod, 85 Carrera, 69 Blood orange 911S, '69 ZL-1, 330 GTC, 308 GTB, Hemi Coronet and some other junk.
Old 07-23-2014, 05:02 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)
Registered User
 
porschetub's Avatar
 
Join Date: Oct 2009
Location: New Zealand
Posts: 1,384
Garage
Quote:
Originally Posted by swbstudios View Post
Hi, I have a 73 914 2.0. It starts and runs fine. When I drive on the highway at 75 or so, it will just shut off. It doesn't really sputter or buck, just shuts down. I coast to a stop, wait about five minutes and it will refire and drive normally. It will then quit at highway speeds after a few minutes. Today, I decided to try and drive home using city streets. The car ran well for over an hour in stop and go city driving. Although it did seem to nearly die at idle once or twice.
Any ideas? coil?
Thanks
I really sounds like the coil is breaking down,so think you are on the right track,whats the general state of the electrical system?,the following comes to mind;
points and condensor,
coil lead,
plug leads (i.e. high resistance issue?)
dizzy cap.
Tell us more
__________________
1985 944 2.7 motor,1989 VW Corrado 16v,57 project plastic speedster t4 power,1992 mk3 Golf,2005 a4 b7 qt avant 3.0 tdi,1987 mk2 Golf GTI,1973 914,2.2t to go in.
Past cars, 17 aircooled VW's and lots of BMW's
KP 13/3/1959-21/11/2014 RIP my best friend.
Old 07-24-2014, 11:55 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #2 (permalink)
Registered User
 
swbstudios's Avatar
 
Join Date: Dec 2006
Location: the OC
Posts: 323
Garage
I plan to check a fresh coil later today. I heard the fuel pump may be the issue, the computer and/or the engine fuse block.
I will also check the ignition components-the odd thing is that it runs fine and will pull to 80 and beyond-then just quits after about ten minutes of highway use.
__________________
67 911 vintage racer twin plug hotrod, 85 Carrera, 69 Blood orange 911S, '69 ZL-1, 330 GTC, 308 GTB, Hemi Coronet and some other junk.
Old 07-24-2014, 02:02 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #3 (permalink)
Registered User
 
porschetub's Avatar
 
Join Date: Oct 2009
Location: New Zealand
Posts: 1,384
Garage
Yea ,think the coil replacement is a good move ,not big $$ afterall be careful to buy the right one as there is some unsuitable/cr#p out there and there have been some reports of failures early in life.
__________________
1985 944 2.7 motor,1989 VW Corrado 16v,57 project plastic speedster t4 power,1992 mk3 Golf,2005 a4 b7 qt avant 3.0 tdi,1987 mk2 Golf GTI,1973 914,2.2t to go in.
Past cars, 17 aircooled VW's and lots of BMW's
KP 13/3/1959-21/11/2014 RIP my best friend.
Old 07-25-2014, 12:49 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #4 (permalink)
TR TR is offline
Registered User
 
TR's Avatar
 
Join Date: Dec 2008
Location: USA
Posts: 749
car just stopping.

Sounds like crapola blocking your fuel filter or tank outlet. That's is exactly what mine did before I pulled the tank. Cleaned it with marine clean, etched it and treated it with Por15. If the car has been sitting the interior or the tank may be corroded and bits of scale are breaking off and blocking the screen or worse blocking the filter or worse getting all the way to the injectors.

I suggest you eliminate what the problem isn't, before you spend money on what you think it is.
Old 07-25-2014, 03:28 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #5 (permalink)
Reply

Thread Tools
Rate This Thread
Rate This Thread:

 


All times are GMT -8. The time now is 02:09 PM.


 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page
 

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.