Pelican Parts
Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   Pelican Parts Technical BBS > 1- Porsche Technical Forums > Porsche 914 & 914-6 Technical Forum

Reply
 
LinkBack Thread Tools Rate Thread
Author
Thread Post New Thread    Reply
Registered User
 
Join Date: Apr 2013
Posts: 20
blinkers won' t work after switch to ledbulbs

Hi there,

I've recenttly changed my lightbulbs from ordinary to led were possible ( parking light and turn signal).
Since then my emergency warning signal, witch puts the four turn signals in action, works fine, but when I try to engage my normal turn signal ( left or right) I have no reaction. The turn signal relay doesn't seem to go, and the fuse is OK, as it goes with the wiper blades etcetera.
What could be the cause?
Thanks in advance for Your reply.

Marc
Zele
Belgium
Old 05-02-2017, 06:38 AM
  Pelican Parts Technical Article Directory    Reply With Quote #1 (permalink)
.
 
Tobra's Avatar
 
Join Date: Aug 2005
Location: Carmichael, CA
Posts: 27,704
Garage
Maybe the LED does not draw enough electricity to get the relay to do its thing
__________________
If you pick up a starving dog and make him prosperous, he will not bite you. This is the principal difference between a dog and a man.
Mark Twain
Old 05-02-2017, 11:53 AM
  Pelican Parts Technical Article Directory    Reply With Quote #2 (permalink)
Registered User
 
Join Date: Oct 2010
Location: Sweden
Posts: 19
Yes you probably need to add an inline resistor or swap the relay. Old relays and LEDs dont play well together.
Old 05-02-2017, 09:03 PM
  Pelican Parts Technical Article Directory    Reply With Quote #3 (permalink)
Registered User
 
Join Date: Feb 2013
Location: Middletown, CT
Posts: 80
https://www.superbrightleds.com/moreinfo/flashers-load-resistors/cf13gl-02-led-bulb-electronic-flasher/782/836/

Of course, it doesn't have a pin for the dash lights, so I can't see that the turn signals are on...but otherwise plugs in and works fine.
Old 05-04-2017, 06:35 AM
  Pelican Parts Technical Article Directory    Reply With Quote #4 (permalink)
Registered User
 
porschetub's Avatar
 
Join Date: Oct 2009
Location: New Zealand
Posts: 1,311
Garage
Never had that issue with mine ,would expect your flasher unit is kaput,sorry.
__________________
1985 944 2.7 motor,1989 VW Corrado 16v,57 project plastic speedster t4 power,1992 mk3 Golf,2005 a4 b7 qt avant 3.0 tdi,1987 mk2 Golf GTI,1973 914,2.2t to go in.
Past cars, 17 aircooled VW's and lots of BMW's
KP 13/3/1959-21/11/2014 RIP my best friend.
Old 06-08-2017, 01:58 PM
  Pelican Parts Technical Article Directory    Reply With Quote #5 (permalink)
Reply

Thread Tools
Rate This Thread
Rate This Thread:

 


All times are GMT -8. The time now is 04:35 PM.


 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2016 Pelican Parts - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page
 

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.