Pelican Parts
Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   Pelican Parts Forums > Porsche Forums > Porsche 924/944/968 Technical Forum


Reply
 
LinkBack Thread Tools Rate Thread
Author
Thread Post New Thread    Reply
Registered User
 
Join Date: Apr 2004
Location: Douglassville PA.
Posts: 407
Garage
Weird Spedo Problem

My 87 944 spedo. has always acted weird. At a 0mph start it will stay a 0 for about 5-10 seconds then all of a sudden it hits where im at. Is this normal ?
__________________
87 944
72 914 Sold
84 944 Sold
85.5 944 Sold
78 924 (first car) RIP
Old 08-21-2004, 08:13 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)
Registered User
 
chapstic2001's Avatar
 
Join Date: Aug 2002
Location: Northern VA
Posts: 517
Send a message via AIM to chapstic2001
Mine does the same. I attribute it to being stuck from lack of lubrication. It tends to happen to cars of this age. I just let it work itself lose rather than ripping into the gauge cluster....for now
__________________
'08 BMW e90 335i 6MT stock [aka 'take two']
'12 Dodge Durango [family hauler]
'86 951 (K&N Cone, Welt Chips, Tial, Zeitronix, P&P O-ring PH Head, WFHG, AFPR) [in storage]
Old 08-21-2004, 09:21 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #2 (permalink)
Reply

Thread Tools
Rate This Thread
Rate This Thread:

 


All times are GMT -8. The time now is 09:56 PM.


 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page
 

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.