Pelican Parts
Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   Pelican Parts Forums > Porsche Forums > Porsche 924/944/968 Technical Forum


Reply
 
LinkBack Thread Tools Rate Thread
Author
Thread Post New Thread    Reply
Registered User
 
paitken76's Avatar
 
Join Date: Dec 2003
Location: Atlanta, Georgia
Posts: 69
Oh ****e, I need help with a Tachometer issue! HELP!

Please help! Driving into work this morning I stared down at my dash while sitting in the usual highway rush hour stand still. I noticed the mileage and then again a few minutes later. Nothing unusual. About five minutes later after moving some distance and bored again I noticed it once more. Only this time nothing was different. And then two miles later when I arrived at work still no change. The damn thing just stopped somethere along the way, both the tachometer and odometer. The speedometer works just lovely but I'm apparently just not going anywhere. Any ideas? Fixes? I have no idea where to start and this is a bad bad thing.....

__________________
Nile Green 1988 Porsche 944 NA
FR Wilk's Power Prom 2
Old 10-18-2004, 12:43 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)
Registered User
 
seaboltman's Avatar
 
Join Date: Jun 2003
Location: Leonardtown, MD
Posts: 838
If im correct, the tach and the odo are run off gears, and it appares yours have broken. I beg someone to correct me if i am wrong about the gears because it sounds right in my head, but i very well may be making this up.
__________________
1987 944 - Wrecked turned parts car
1986 944 - Awesome Auto
Old 10-18-2004, 02:44 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #2 (permalink)
Registered User
 
paitken76's Avatar
 
Join Date: Dec 2003
Location: Atlanta, Georgia
Posts: 69
Hummm.

Well I drove home hoping that is was some sort of fluke this morning but no, its broken. I didnt travel a fragment of a mile according to my 944. So you think its gears? I thought is might have been magnets on the drive shaft or something like that... I have no clue. My old Honda (same year as the Porsche) uses the old cable that nicely plugs in to the back on the instrument. Since our cars have a digital computer cable type attachment and the spedomter portion of the instrument works I was thinking maybe theirs a sending unit or something.... Anyone, anyone?

For sure someone has had this problem before and can fix it? (I hope)
__________________
Nile Green 1988 Porsche 944 NA
FR Wilk's Power Prom 2
Old 10-18-2004, 04:04 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #3 (permalink)
Moderator
 
AFJuvat's Avatar
 
Join Date: Feb 2001
Location: Viera FL
Posts: 5,643
Check the fuse and the the grounds behind the instrument cluster

AFJuvat
__________________
Es geht nicht darum wie schnell man faehrt, sondern wie gut man schnell fahren kann.

Ihr Brunnen der nutzlosen Porsche Information
Old 10-18-2004, 05:02 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #4 (permalink)
Registered User
 
paitken76's Avatar
 
Join Date: Dec 2003
Location: Atlanta, Georgia
Posts: 69
Thanks for the input. I already checked the fuse, it was fine. After all I didnt lose the instruments just the tach / odometer. Has to be something more specific dont you think? As far as the grounds...what should I be looking for? Behind the unit there are only the four circuit connections which I know are seated well and locked. Is there something else bacl there I'm not aware of? Thanks again.
__________________
Nile Green 1988 Porsche 944 NA
FR Wilk's Power Prom 2
Old 10-18-2004, 06:53 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #5 (permalink)
Registered User
 
livewirevoodoo's Avatar
 
Join Date: Jul 2004
Location: New Haven, CT
Posts: 1,135
Garage
I think the two main causes of odometer failure are 1) the odometer drive gear sliding down the shaft it is mounted on and disengaging from the other gears, or 2) the gear (cheap plastic) corroding over time, missing teeth, etc..

I took my instrument cluster out this weekend to refurb my instrument light cluster and noticed both symptoms with my gear (odometer stopped worked 1500 miles after purschasing car). After sliding the gear back down the shaft to engage it and the worm gear, I got about 4/10ths of a mile before the trip meter stopped working again Looks like the gear is missing some teeth, time to replace it. I've seen them offered online for ~25 or so.
__________________
''87 944na 85k
C02 / M158 / M418 / M425 / M431 / M454 / M533 / M650 / M946

'94 Oldsmobile 88 Royale (winter beater)

Its not what you drive, its what drives you.
Old 10-19-2004, 05:52 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #6 (permalink)
 
Registered User
 
Zero10's Avatar
 
Join Date: Nov 2003
Location: Calgary, AB
Posts: 1,883
Send a message via ICQ to Zero10
If both the odometer and the tach are out, and went out at the same time, it's electrical.
The tach is impulse driven by the DME.
I had my instrument cluster out a few times, and once I got a bit of dust/dirt on one of the connectors when I re-connected it. After about 500km's, the odo stopped working, and about 3 days later, the speedo and tach as well.
Cleaned up the connectors, and all is well.
__________________
2010 Hyundai Elantra Touring, GLS 5 speed, Indigo Blue Metallic. 2.0L of Korean fury!

Buy my parts!
Old 10-19-2004, 03:38 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #7 (permalink)
Registered User
 
Join Date: Dec 2002
Location: www.fakelife.com
Posts: 1,672
Send a message via AIM to SlowToady
/*Thread-jack*/

Being that the tach is driven by the DME, I'm assuming something is getting wet and that is why my tach usually won't work when it's raining? Any ideas on what to check first?
__________________
I turn away with fear and horror from this lamentable sore of continuous functions without derivatives. --Charles Hermite

Fakelife.com Nothing to do with archery anymore. Porsche/BMW/Ferrari/Honda videos
Old 10-20-2004, 05:50 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #8 (permalink)
Registered User
 
paitken76's Avatar
 
Join Date: Dec 2003
Location: Atlanta, Georgia
Posts: 69
Crossing my fingers, thanks.

Thanks to all for the feedback so far and I empathise with those sharing my agony. Special thanks to "livewirevoodoo" for added info. I'm trying to wait until this weekend to give all the suggestions a go. Work ahs been crazy and the rain has hampered things a bit since I work on my car on the driveway. Hopefully I'll have some good news Saturday or Sunday evening for the forum.

__________________
Nile Green 1988 Porsche 944 NA
FR Wilk's Power Prom 2
Old 10-20-2004, 08:44 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #9 (permalink)
Reply

Thread Tools
Rate This Thread
Rate This Thread:

 


All times are GMT -8. The time now is 01:49 AM.


 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2020 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page
 

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.